import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|[^<>])\\b((?:https?|ftp):\\/\\/[^<>\\s]+\\b)";
final String string = "http://www.google.com here and https://google.com ftp://google.com \n"
+ "<http://www.google.com> here and <https://google.com> <ftp://google.com>";
final String subst = "$1<a href=\"$2\">$2</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}