const regex = /(^|[^<>])\b((?:https?|ftp):\/\/[^<>\s]+\b)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|[^<>])\\b((?:https?|ftp):\\\/\\\/[^<>\\s]+\\b)', 'gi')
const str = `http://www.google.com here and https://google.com ftp://google.com
<http://www.google.com> here and <https://google.com> <ftp://google.com>`;
const subst = `$1<a href="$2">$2</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);