using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z]{2}\.?[0-9]{2}\.?[a-zA-Z0-9]{4}\.?[0-9]{7,21}";
string input = @"a123-562
avcd-fe2
CH1231231234567
CH5800791123000889012
AL472121100900000002356987411";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}