// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z]{2}\.?[0-9]{2}\.?[a-zA-Z0-9]{4}\.?[0-9]{7,21}").unwrap();
let string = "a123-562
avcd-fe2
CH1231231234567
CH5800791123000889012
AL472121100900000002356987411";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}