$re = '/^[a-zA-Z]{2}\.?[0-9]{2}\.?[a-zA-Z0-9]{4}\.?[0-9]{7,21}/m';
$str = 'a123-562
avcd-fe2
CH1231231234567
CH5800791123000889012
AL472121100900000002356987411';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);