import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z]{2}\\.?[0-9]{2}\\.?[a-zA-Z0-9]{4}\\.?[0-9]{7,21}";
final String string = "a123-562\n"
+ "avcd-fe2\n"
+ "CH1231231234567\n"
+ "CH5800791123000889012\n"
+ "AL472121100900000002356987411";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}