using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:""?([^""]*)""?,){2}";
string substitution = @"bar";
string input = @"196778,""df,fdfsdf"",""4.4"",""ds-sdads231-33"",""mmh"",1023,1,""20150,62519535TY""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}