use strict;
my $str = '196778,"df,fdfsdf","4.4","ds-sdads231-33","mmh",1023,1,"20150,62519535TY"';
my $regex = qr/(?:"?([^"]*)"?,){2}/p;
my $subst = 'bar';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";