import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\"?([^\"]*)\"?,){2}";
final String string = "196778,\"df,fdfsdf\",\"4.4\",\"ds-sdads231-33\",\"mmh\",1023,1,\"20150,62519535TY\"";
final String subst = "bar";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}