const regex = /^((?:[^|\n]*\|){3})(?![\r\n])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:[^|\\n]*\\|){3})(?![\\r\\n])', 'gm')
const str = `John Doe|1hgds234|Some comment|
Mary Jane|5df678|This column is the end of this record|Harry Jones|3456|Harry's record should be on the next line|
Sue Anderson|037dsf533|Another comment`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);