use strict;
my $str = 'John Doe|1hgds234|Some comment|
Mary Jane|5df678|This column is the end of this record|Harry Jones|3456|Harry\'s record should be on the next line|
Sue Anderson|037dsf533|Another comment';
my $regex = qr/^((?:[^|\n]*\|){3})(?![\r\n])/mp;
my $subst = '$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";