import re
regex = re.compile(r"^((?:[^|\n]*\|){3})(?![\r\n])", flags=re.MULTILINE)
test_str = ("John Doe|1hgds234|Some comment|\n"
"Mary Jane|5df678|This column is the end of this record|Harry Jones|3456|Harry's record should be on the next line|\n"
"Sue Anderson|037dsf533|Another comment")
subst = "$1\\n"
result = regex.sub(subst, test_str)
if result:
print(result)