$re = '/^((?:[^|\n]*\|){3})(?![\r\n])/m';
$str = 'John Doe|1hgds234|Some comment|
Mary Jane|5df678|This column is the end of this record|Harry Jones|3456|Harry\'s record should be on the next line|
Sue Anderson|037dsf533|Another comment';
$subst = "$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;