const regex = /Frau+\s+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Frau+\\s+', 'g')
const str = `Phone 12345 aa / bb
Phone is 12345 aa / bb
Phone is this 12354 aa / bb
Frau Eva`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}