re = /Frau+\s+/
str = 'Phone 12345 aa / bb
Phone is 12345 aa / bb
Phone is this 12354 aa / bb
Frau Eva'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end