#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[^<>()[\]\\,;:\%#^\s@\"$&!@]+@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\])|(([a-zA-Z0-9]+\.)+[a-zA-Z]{2,}))$"
Local $sString = "hello!%#%^world@gmail.com" & @CRLF & _
"helloworld@-gmail.com" & @CRLF & _
"hello-world@gmail.com" & @CRLF & _
"hello.world@gmail.com" & @CRLF & _
"hello!#%#@gmail.com" & @CRLF & _
"helloworld@-gmail.com" & @CRLF & _
"helloworld@gmail.com" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)