const regex = /^[^<>()[\]\\,;:\%#^\s@\"$&!@]+@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\])|(([a-zA-Z0-9]+\.)+[a-zA-Z]{2,}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^<>()[\\]\\\\,;:\\%#^\\s@\\"$&!@]+@((\\[[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\])|(([a-zA-Z0-9]+\\.)+[a-zA-Z]{2,}))$', 'gm')
const str = `hello!%#%^world@gmail.com
helloworld@-gmail.com
hello-world@gmail.com
hello.world@gmail.com
hello!#%#@gmail.com
helloworld@-gmail.com
helloworld@gmail.com
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);