using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^<>()[\]\\,;:\%#^\s@\""$&!@]+@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\])|(([a-zA-Z0-9]+\.)+[a-zA-Z]{2,}))$";
string substitution = @"";
string input = @"hello!%#%^world@gmail.com
helloworld@-gmail.com
hello-world@gmail.com
hello.world@gmail.com
hello!#%#@gmail.com
helloworld@-gmail.com
helloworld@gmail.com
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}