use strict;
my $str = 'hello!%#%^world@gmail.com
helloworld@-gmail.com
hello-world@gmail.com
hello.world@gmail.com
hello!#%#@gmail.com
helloworld@-gmail.com
helloworld@gmail.com
';
my $regex = qr/^[^<>()[\]\\,;:\%#^\s@\"$&!@]+@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\])|(([a-zA-Z0-9]+\.)+[a-zA-Z]{2,}))$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";