import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^?#]+).*";
final String string = "https://studio.grabyo.com/home.jsp#stream/fBCyXMbtgHQ/share\n"
+ "https://studio.grabyo.com/studiolibrary.jsp?channelId=hkWw8oRUtPA\n"
+ "https://studio.grabyo.com/trim.jsp?campaignId=AQiJBGfoaJs&streamId=TCiHdVdqoBe\n"
+ "https://studio.grabyo.com/studiolibrary.jsp?streamId=TCiHdVdqoBe&galleryId=AQiJBGfoaJs\n"
+ "https://studio.grabyo.com/studiolibrary.jsp?campaignId=qzNPNPKTmry\n"
+ "https://studio.grabyo.com/trim.jsp?channelId=1dnc0Cjw9Ze\n"
+ "https://studio.grabyo.com/trim.jsp?campaignId=AQiJBGfoaJs\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}