import re
regex = re.compile(r"^([^?#]+).*", flags=re.MULTILINE)
test_str = ("https://studio.grabyo.com/home.jsp#stream/fBCyXMbtgHQ/share\n"
"https://studio.grabyo.com/studiolibrary.jsp?channelId=hkWw8oRUtPA\n"
"https://studio.grabyo.com/trim.jsp?campaignId=AQiJBGfoaJs&streamId=TCiHdVdqoBe\n"
"https://studio.grabyo.com/studiolibrary.jsp?streamId=TCiHdVdqoBe&galleryId=AQiJBGfoaJs\n"
"https://studio.grabyo.com/studiolibrary.jsp?campaignId=qzNPNPKTmry\n"
"https://studio.grabyo.com/trim.jsp?channelId=1dnc0Cjw9Ze\n"
"https://studio.grabyo.com/trim.jsp?campaignId=AQiJBGfoaJs\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")