// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^?#]+).*").unwrap();
let string = "https://studio.grabyo.com/home.jsp#stream/fBCyXMbtgHQ/share
https://studio.grabyo.com/studiolibrary.jsp?channelId=hkWw8oRUtPA
https://studio.grabyo.com/trim.jsp?campaignId=AQiJBGfoaJs&streamId=TCiHdVdqoBe
https://studio.grabyo.com/studiolibrary.jsp?streamId=TCiHdVdqoBe&galleryId=AQiJBGfoaJs
https://studio.grabyo.com/studiolibrary.jsp?campaignId=qzNPNPKTmry
https://studio.grabyo.com/trim.jsp?channelId=1dnc0Cjw9Ze
https://studio.grabyo.com/trim.jsp?campaignId=AQiJBGfoaJs
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}