#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?simu)^\+[\d]{1}+\([\d]{3}\)+[\d]{3}+\-+[\d]{4}$|^\+[\d]{1}+\([\d]{3}\)+[\d]{3}+\s+[\d]{4}$|^\+[0-9]{1}+\([0-9]{3}\)+[0-9]{7}$|^\+[0-9]{1}+\([0-9]{3}\)+[0-9]{3}+\-+[0-9]{2}+\-+[0-9]{2}$|^\+[0-9]{1}+\([0-9]{3}\)+[0-9]{3}+\s+[0-9]{2}+\s+[0-9]{2}$|^\+[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\s+[0-9]{2}+\s+[0-9]{2}$|^\+[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\-+[0-9]{2}+\-+[0-9]{2}$|^\++[0-9]{4}+\s+[0-9]{7}$|^\+[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\s+[0-9]{4}$|^\+[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\-+[0-9]{4}$|^\++[0-9]{11}$|^[0-9]{1}+\([0-9]{3}\)+[0-9]{7}$|^[0-9]{1}+\([0-9]{3}\)+[0-9]{3}+\-+[0-9]{2}+\-+[0-9]{2}$|^[0-9]{1}+\([0-9]{3}\)+[0-9]{3}+\s[0-9]{2}+\s+[0-9]{2}$|^\([0-9]{3}\)+[0-9]{7}$|^\([0-9]{3}\)+[0-9]{3}+\-+[0-9]{2}+\-+[0-9]{2}$|^\([0-9]{3}\)+[0-9]{3}+\s+[0-9]{2}+\s+[0-9]{2}$|^[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\s+[0-9]{2}+\s+[0-9]{2}$|^[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\-+[0-9]{2}+\-+[0-9]{2}$|^[0-9]{4}+\s+[0-9]{7}$|^[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\s+[0-9]{4}$|^[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\-+[0-9]{4}$|^[\d]{11}$|^[\d]{10}$|^\+[\d]{1}+\([\d]{3}\)+[\d]{2}+\s+[\d]{3}+\-+[\d]{2}$|^\+[\d]{1}+\([\d]{3}\)+[\d]{2}+\s+[\d]{3}+\s+[\d]{2}$|^\+[\d]{1}+\([\d]{3}\)+[\d]{2}+\s+[\d]{5}$|^\+[\d]{6}+\s+[\d]{3}+\-+[\d]{2}$|^\+[\d]{6}+\s+[\d]{3}+\s+[\d]{2}$|^\+[\d]{6}+\s+[\d]{5}$|^\+[\d]{4}+\s+[\d]{2}+\s+[\d]{3}+\s+[\d]{2}$|^\+[\d]{4}+\s+[\d]{2}+\s+[\d]{3}+\-+[\d]{2}$|^\+[\d]{11}$|^[\d]+\([\d]{3}\)+[\d]{2}+\s+[\d]{3}+\-+[\d]{2}$|^[\d]+\([\d]{3}\)+[\d]{2}+\s+[\d]{3}+\s+[\d]{2}$|^[\d]+\([\d]{3}\)+[\d]{2}+\s+[\d]{5}$|^[\d]{6}+\s+[\d]{3}+\-+[\d]{2}$|^[\d]{6}+\s+[\d]{3}+\s+[\d]{2}$|^[\d]{6}+\s+[\d]{5}$|^[\d]{4}+\s+[\d]{2}+\s+[\d]{3}+\s+[\d]{2}$|^[\d]{4}+\s+[\d]{2}+\s+[\d]{3}+\-+[\d]{2}$|^[\d]{3}+\-+[\d]{2}$|^[\d]{5}$"
Local $sString = "+7(931)317 2764" & @CRLF & _
"+7(931)3172764" & @CRLF & _
"+7(931)317-27-64" & @CRLF & _
"+7(931)317 27 64" & @CRLF & _
"+7 931 317 27 64" & @CRLF & _
"+7 931 317-27-64" & @CRLF & _
"+7931 3172764" & @CRLF & _
"+7 931 317 2764" & @CRLF & _
"+7 931 317-2764" & @CRLF & _
"+79313172764" & @CRLF & _
"7(931)3172764" & @CRLF & _
"7(931)317-27-64" & @CRLF & _
"7(931)317 27 64" & @CRLF & _
"(931)3172764" & @CRLF & _
"(931)317-27-64" & @CRLF & _
"(931)317 27 64" & @CRLF & _
"7 931 317 27 64" & @CRLF & _
"7 931 317-27-64" & @CRLF & _
"7931 3172764" & @CRLF & _
"7 931 317 2764" & @CRLF & _
"7 931 317-2764" & @CRLF & _
"79313172764" & @CRLF & _
"9313172764"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")