import re
regex = re.compile(r"^\+[\d]{1}+\([\d]{3}\)+[\d]{3}+\-+[\d]{4}$|^\+[\d]{1}+\([\d]{3}\)+[\d]{3}+\s+[\d]{4}$|^\+[0-9]{1}+\([0-9]{3}\)+[0-9]{7}$|^\+[0-9]{1}+\([0-9]{3}\)+[0-9]{3}+\-+[0-9]{2}+\-+[0-9]{2}$|^\+[0-9]{1}+\([0-9]{3}\)+[0-9]{3}+\s+[0-9]{2}+\s+[0-9]{2}$|^\+[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\s+[0-9]{2}+\s+[0-9]{2}$|^\+[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\-+[0-9]{2}+\-+[0-9]{2}$|^\++[0-9]{4}+\s+[0-9]{7}$|^\+[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\s+[0-9]{4}$|^\+[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\-+[0-9]{4}$|^\++[0-9]{11}$|^[0-9]{1}+\([0-9]{3}\)+[0-9]{7}$|^[0-9]{1}+\([0-9]{3}\)+[0-9]{3}+\-+[0-9]{2}+\-+[0-9]{2}$|^[0-9]{1}+\([0-9]{3}\)+[0-9]{3}+\s[0-9]{2}+\s+[0-9]{2}$|^\([0-9]{3}\)+[0-9]{7}$|^\([0-9]{3}\)+[0-9]{3}+\-+[0-9]{2}+\-+[0-9]{2}$|^\([0-9]{3}\)+[0-9]{3}+\s+[0-9]{2}+\s+[0-9]{2}$|^[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\s+[0-9]{2}+\s+[0-9]{2}$|^[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\-+[0-9]{2}+\-+[0-9]{2}$|^[0-9]{4}+\s+[0-9]{7}$|^[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\s+[0-9]{4}$|^[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\-+[0-9]{4}$|^[\d]{11}$|^[\d]{10}$|^\+[\d]{1}+\([\d]{3}\)+[\d]{2}+\s+[\d]{3}+\-+[\d]{2}$|^\+[\d]{1}+\([\d]{3}\)+[\d]{2}+\s+[\d]{3}+\s+[\d]{2}$|^\+[\d]{1}+\([\d]{3}\)+[\d]{2}+\s+[\d]{5}$|^\+[\d]{6}+\s+[\d]{3}+\-+[\d]{2}$|^\+[\d]{6}+\s+[\d]{3}+\s+[\d]{2}$|^\+[\d]{6}+\s+[\d]{5}$|^\+[\d]{4}+\s+[\d]{2}+\s+[\d]{3}+\s+[\d]{2}$|^\+[\d]{4}+\s+[\d]{2}+\s+[\d]{3}+\-+[\d]{2}$|^\+[\d]{11}$|^[\d]+\([\d]{3}\)+[\d]{2}+\s+[\d]{3}+\-+[\d]{2}$|^[\d]+\([\d]{3}\)+[\d]{2}+\s+[\d]{3}+\s+[\d]{2}$|^[\d]+\([\d]{3}\)+[\d]{2}+\s+[\d]{5}$|^[\d]{6}+\s+[\d]{3}+\-+[\d]{2}$|^[\d]{6}+\s+[\d]{3}+\s+[\d]{2}$|^[\d]{6}+\s+[\d]{5}$|^[\d]{4}+\s+[\d]{2}+\s+[\d]{3}+\s+[\d]{2}$|^[\d]{4}+\s+[\d]{2}+\s+[\d]{3}+\-+[\d]{2}$|^[\d]{3}+\-+[\d]{2}$|^[\d]{5}$", flags=re.DOTALL | re.IGNORECASE | re.MULTILINE | re.UNICODE)
test_str = ("+7(931)317 2764\n"
"+7(931)3172764\n"
"+7(931)317-27-64\n"
"+7(931)317 27 64\n"
"+7 931 317 27 64\n"
"+7 931 317-27-64\n"
"+7931 3172764\n"
"+7 931 317 2764\n"
"+7 931 317-2764\n"
"+79313172764\n"
"7(931)3172764\n"
"7(931)317-27-64\n"
"7(931)317 27 64\n"
"(931)3172764\n"
"(931)317-27-64\n"
"(931)317 27 64\n"
"7 931 317 27 64\n"
"7 931 317-27-64\n"
"7931 3172764\n"
"7 931 317 2764\n"
"7 931 317-2764\n"
"79313172764\n"
"9313172764")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")