using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\+[\d]{1}+\([\d]{3}\)+[\d]{3}+\-+[\d]{4}$|^\+[\d]{1}+\([\d]{3}\)+[\d]{3}+\s+[\d]{4}$|^\+[0-9]{1}+\([0-9]{3}\)+[0-9]{7}$|^\+[0-9]{1}+\([0-9]{3}\)+[0-9]{3}+\-+[0-9]{2}+\-+[0-9]{2}$|^\+[0-9]{1}+\([0-9]{3}\)+[0-9]{3}+\s+[0-9]{2}+\s+[0-9]{2}$|^\+[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\s+[0-9]{2}+\s+[0-9]{2}$|^\+[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\-+[0-9]{2}+\-+[0-9]{2}$|^\++[0-9]{4}+\s+[0-9]{7}$|^\+[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\s+[0-9]{4}$|^\+[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\-+[0-9]{4}$|^\++[0-9]{11}$|^[0-9]{1}+\([0-9]{3}\)+[0-9]{7}$|^[0-9]{1}+\([0-9]{3}\)+[0-9]{3}+\-+[0-9]{2}+\-+[0-9]{2}$|^[0-9]{1}+\([0-9]{3}\)+[0-9]{3}+\s[0-9]{2}+\s+[0-9]{2}$|^\([0-9]{3}\)+[0-9]{7}$|^\([0-9]{3}\)+[0-9]{3}+\-+[0-9]{2}+\-+[0-9]{2}$|^\([0-9]{3}\)+[0-9]{3}+\s+[0-9]{2}+\s+[0-9]{2}$|^[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\s+[0-9]{2}+\s+[0-9]{2}$|^[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\-+[0-9]{2}+\-+[0-9]{2}$|^[0-9]{4}+\s+[0-9]{7}$|^[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\s+[0-9]{4}$|^[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\-+[0-9]{4}$|^[\d]{11}$|^[\d]{10}$|^\+[\d]{1}+\([\d]{3}\)+[\d]{2}+\s+[\d]{3}+\-+[\d]{2}$|^\+[\d]{1}+\([\d]{3}\)+[\d]{2}+\s+[\d]{3}+\s+[\d]{2}$|^\+[\d]{1}+\([\d]{3}\)+[\d]{2}+\s+[\d]{5}$|^\+[\d]{6}+\s+[\d]{3}+\-+[\d]{2}$|^\+[\d]{6}+\s+[\d]{3}+\s+[\d]{2}$|^\+[\d]{6}+\s+[\d]{5}$|^\+[\d]{4}+\s+[\d]{2}+\s+[\d]{3}+\s+[\d]{2}$|^\+[\d]{4}+\s+[\d]{2}+\s+[\d]{3}+\-+[\d]{2}$|^\+[\d]{11}$|^[\d]+\([\d]{3}\)+[\d]{2}+\s+[\d]{3}+\-+[\d]{2}$|^[\d]+\([\d]{3}\)+[\d]{2}+\s+[\d]{3}+\s+[\d]{2}$|^[\d]+\([\d]{3}\)+[\d]{2}+\s+[\d]{5}$|^[\d]{6}+\s+[\d]{3}+\-+[\d]{2}$|^[\d]{6}+\s+[\d]{3}+\s+[\d]{2}$|^[\d]{6}+\s+[\d]{5}$|^[\d]{4}+\s+[\d]{2}+\s+[\d]{3}+\s+[\d]{2}$|^[\d]{4}+\s+[\d]{2}+\s+[\d]{3}+\-+[\d]{2}$|^[\d]{3}+\-+[\d]{2}$|^[\d]{5}$";
string input = @"+7(931)317 2764
+7(931)3172764
+7(931)317-27-64
+7(931)317 27 64
+7 931 317 27 64
+7 931 317-27-64
+7931 3172764
+7 931 317 2764
+7 931 317-2764
+79313172764
7(931)3172764
7(931)317-27-64
7(931)317 27 64
(931)3172764
(931)317-27-64
(931)317 27 64
7 931 317 27 64
7 931 317-27-64
7931 3172764
7 931 317 2764
7 931 317-2764
79313172764
9313172764";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase | RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}