const regex = /^\+[\d]{1}+\([\d]{3}\)+[\d]{3}+\-+[\d]{4}$|^\+[\d]{1}+\([\d]{3}\)+[\d]{3}+\s+[\d]{4}$|^\+[0-9]{1}+\([0-9]{3}\)+[0-9]{7}$|^\+[0-9]{1}+\([0-9]{3}\)+[0-9]{3}+\-+[0-9]{2}+\-+[0-9]{2}$|^\+[0-9]{1}+\([0-9]{3}\)+[0-9]{3}+\s+[0-9]{2}+\s+[0-9]{2}$|^\+[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\s+[0-9]{2}+\s+[0-9]{2}$|^\+[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\-+[0-9]{2}+\-+[0-9]{2}$|^\++[0-9]{4}+\s+[0-9]{7}$|^\+[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\s+[0-9]{4}$|^\+[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\-+[0-9]{4}$|^\++[0-9]{11}$|^[0-9]{1}+\([0-9]{3}\)+[0-9]{7}$|^[0-9]{1}+\([0-9]{3}\)+[0-9]{3}+\-+[0-9]{2}+\-+[0-9]{2}$|^[0-9]{1}+\([0-9]{3}\)+[0-9]{3}+\s[0-9]{2}+\s+[0-9]{2}$|^\([0-9]{3}\)+[0-9]{7}$|^\([0-9]{3}\)+[0-9]{3}+\-+[0-9]{2}+\-+[0-9]{2}$|^\([0-9]{3}\)+[0-9]{3}+\s+[0-9]{2}+\s+[0-9]{2}$|^[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\s+[0-9]{2}+\s+[0-9]{2}$|^[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\-+[0-9]{2}+\-+[0-9]{2}$|^[0-9]{4}+\s+[0-9]{7}$|^[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\s+[0-9]{4}$|^[0-9]{1}+\s+[0-9]{3}+\s+[0-9]{3}+\-+[0-9]{4}$|^[\d]{11}$|^[\d]{10}$|^\+[\d]{1}+\([\d]{3}\)+[\d]{2}+\s+[\d]{3}+\-+[\d]{2}$|^\+[\d]{1}+\([\d]{3}\)+[\d]{2}+\s+[\d]{3}+\s+[\d]{2}$|^\+[\d]{1}+\([\d]{3}\)+[\d]{2}+\s+[\d]{5}$|^\+[\d]{6}+\s+[\d]{3}+\-+[\d]{2}$|^\+[\d]{6}+\s+[\d]{3}+\s+[\d]{2}$|^\+[\d]{6}+\s+[\d]{5}$|^\+[\d]{4}+\s+[\d]{2}+\s+[\d]{3}+\s+[\d]{2}$|^\+[\d]{4}+\s+[\d]{2}+\s+[\d]{3}+\-+[\d]{2}$|^\+[\d]{11}$|^[\d]+\([\d]{3}\)+[\d]{2}+\s+[\d]{3}+\-+[\d]{2}$|^[\d]+\([\d]{3}\)+[\d]{2}+\s+[\d]{3}+\s+[\d]{2}$|^[\d]+\([\d]{3}\)+[\d]{2}+\s+[\d]{5}$|^[\d]{6}+\s+[\d]{3}+\-+[\d]{2}$|^[\d]{6}+\s+[\d]{3}+\s+[\d]{2}$|^[\d]{6}+\s+[\d]{5}$|^[\d]{4}+\s+[\d]{2}+\s+[\d]{3}+\s+[\d]{2}$|^[\d]{4}+\s+[\d]{2}+\s+[\d]{3}+\-+[\d]{2}$|^[\d]{3}+\-+[\d]{2}$|^[\d]{5}$/gsimu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+[\\d]{1}+\\([\\d]{3}\\)+[\\d]{3}+\\-+[\\d]{4}$|^\\+[\\d]{1}+\\([\\d]{3}\\)+[\\d]{3}+\\s+[\\d]{4}$|^\\+[0-9]{1}+\\([0-9]{3}\\)+[0-9]{7}$|^\\+[0-9]{1}+\\([0-9]{3}\\)+[0-9]{3}+\\-+[0-9]{2}+\\-+[0-9]{2}$|^\\+[0-9]{1}+\\([0-9]{3}\\)+[0-9]{3}+\\s+[0-9]{2}+\\s+[0-9]{2}$|^\\+[0-9]{1}+\\s+[0-9]{3}+\\s+[0-9]{3}+\\s+[0-9]{2}+\\s+[0-9]{2}$|^\\+[0-9]{1}+\\s+[0-9]{3}+\\s+[0-9]{3}+\\-+[0-9]{2}+\\-+[0-9]{2}$|^\\++[0-9]{4}+\\s+[0-9]{7}$|^\\+[0-9]{1}+\\s+[0-9]{3}+\\s+[0-9]{3}+\\s+[0-9]{4}$|^\\+[0-9]{1}+\\s+[0-9]{3}+\\s+[0-9]{3}+\\-+[0-9]{4}$|^\\++[0-9]{11}$|^[0-9]{1}+\\([0-9]{3}\\)+[0-9]{7}$|^[0-9]{1}+\\([0-9]{3}\\)+[0-9]{3}+\\-+[0-9]{2}+\\-+[0-9]{2}$|^[0-9]{1}+\\([0-9]{3}\\)+[0-9]{3}+\\s[0-9]{2}+\\s+[0-9]{2}$|^\\([0-9]{3}\\)+[0-9]{7}$|^\\([0-9]{3}\\)+[0-9]{3}+\\-+[0-9]{2}+\\-+[0-9]{2}$|^\\([0-9]{3}\\)+[0-9]{3}+\\s+[0-9]{2}+\\s+[0-9]{2}$|^[0-9]{1}+\\s+[0-9]{3}+\\s+[0-9]{3}+\\s+[0-9]{2}+\\s+[0-9]{2}$|^[0-9]{1}+\\s+[0-9]{3}+\\s+[0-9]{3}+\\-+[0-9]{2}+\\-+[0-9]{2}$|^[0-9]{4}+\\s+[0-9]{7}$|^[0-9]{1}+\\s+[0-9]{3}+\\s+[0-9]{3}+\\s+[0-9]{4}$|^[0-9]{1}+\\s+[0-9]{3}+\\s+[0-9]{3}+\\-+[0-9]{4}$|^[\\d]{11}$|^[\\d]{10}$|^\\+[\\d]{1}+\\([\\d]{3}\\)+[\\d]{2}+\\s+[\\d]{3}+\\-+[\\d]{2}$|^\\+[\\d]{1}+\\([\\d]{3}\\)+[\\d]{2}+\\s+[\\d]{3}+\\s+[\\d]{2}$|^\\+[\\d]{1}+\\([\\d]{3}\\)+[\\d]{2}+\\s+[\\d]{5}$|^\\+[\\d]{6}+\\s+[\\d]{3}+\\-+[\\d]{2}$|^\\+[\\d]{6}+\\s+[\\d]{3}+\\s+[\\d]{2}$|^\\+[\\d]{6}+\\s+[\\d]{5}$|^\\+[\\d]{4}+\\s+[\\d]{2}+\\s+[\\d]{3}+\\s+[\\d]{2}$|^\\+[\\d]{4}+\\s+[\\d]{2}+\\s+[\\d]{3}+\\-+[\\d]{2}$|^\\+[\\d]{11}$|^[\\d]+\\([\\d]{3}\\)+[\\d]{2}+\\s+[\\d]{3}+\\-+[\\d]{2}$|^[\\d]+\\([\\d]{3}\\)+[\\d]{2}+\\s+[\\d]{3}+\\s+[\\d]{2}$|^[\\d]+\\([\\d]{3}\\)+[\\d]{2}+\\s+[\\d]{5}$|^[\\d]{6}+\\s+[\\d]{3}+\\-+[\\d]{2}$|^[\\d]{6}+\\s+[\\d]{3}+\\s+[\\d]{2}$|^[\\d]{6}+\\s+[\\d]{5}$|^[\\d]{4}+\\s+[\\d]{2}+\\s+[\\d]{3}+\\s+[\\d]{2}$|^[\\d]{4}+\\s+[\\d]{2}+\\s+[\\d]{3}+\\-+[\\d]{2}$|^[\\d]{3}+\\-+[\\d]{2}$|^[\\d]{5}$', 'gsimu')
const str = `+7(931)317 2764
+7(931)3172764
+7(931)317-27-64
+7(931)317 27 64
+7 931 317 27 64
+7 931 317-27-64
+7931 3172764
+7 931 317 2764
+7 931 317-2764
+79313172764
7(931)3172764
7(931)317-27-64
7(931)317 27 64
(931)3172764
(931)317-27-64
(931)317 27 64
7 931 317 27 64
7 931 317-27-64
7931 3172764
7 931 317 2764
7 931 317-2764
79313172764
9313172764`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}