$re = '/(?s)<div[^>]*>.*<img.*src=\"([^"]+)\".*<\/div>/mi';
$str = '<div class="header__logo"><a class="logotype" href="http://wpengine.com" data-wpel-link="internal"></a></div>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);