import re
regex = re.compile(r"(?s)<div[^>]*>.*<img.*src=\"([^\"]+)\".*<\/div>", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("<div class=\"header__logo\"><a class=\"logotype\" href=\"http://wpengine.com\" data-wpel-link=\"internal\"></a></div>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")