re = /(?s)<div[^>]*>.*<img.*src=\"([^"]+)\".*<\/div>/mi
str = '<div class="header__logo"><a class="logotype" href="http://wpengine.com" data-wpel-link="internal"></a></div>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end