using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Trident\/7\.";
string input = @"Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.3; Trident/4.0; Touch)
Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.3; Trident/7.0; Touch)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}