$re = '/^(?<token>[\w\-]+|BREAKING CHANGE)(?<seperator>: | #)(?<value>.*?(?=^([\w\-]+|BREAKING CHANGE)(: | #)))/ms';
$str = 'Fixes: 849fa50662fb ("bpf/verifier: refine retval R0 state
for bpf_get_stack helper")
Reported-by: Lorenzo Fontana <fontanal
orenz@gmail.com>
Reported-by: Leonardo Di Donato <leodidonato@gmail.com>
Reported-by: John Fastabend <john.fastabend@gmail.com>
Signed-off-by: Daniel Borkmann <daniel@iogearbox.net>
Acked-by: Alexei Starovoitov <ast@kernel.org>
f
fffffff
Acked-by: John Fastabend <john.fastabend@gmail.com>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);