using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^blog/(?P<blog_id>\d+)/(?P<slug>[^/\n]+)/?$";
string input = @"blog/12/بلاگ-مثال";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}