package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^blog/(?P<blog_id>\d+)/(?P<slug>[^/\n]+)/?$`)
var str = `blog/12/بلاگ-مثال`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}