$re = '/^blog/(?P<blog_id>\d+)/(?P<slug>[^/\n]+)/?$/m';
$str = 'blog/12/بلاگ-مثال';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);