#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^\s*([-+]?[0-9]*\.[0-9]+([eE][-+]?[0-9]+)?)$ #float" & @CRLF & _
"| # or" & @CRLF & _
"^(\d{1,2})$ # 2 digit int"
Local $sString = "Pass:" & @CRLF & _
"1" & @CRLF & _
"12" & @CRLF & _
"12.3" & @CRLF & _
".3" & @CRLF & _
"12.3456789" & @CRLF & _
"+12.3" & @CRLF & _
"-12.3" & @CRLF & _
"" & @CRLF & _
"Fail" & @CRLF & _
"123" & @CRLF & _
"12." & @CRLF & _
"abc" & @CRLF & _
"12..34" & @CRLF & _
"--12.3" & @CRLF & _
"." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")