$re = '/^\s*([-+]?[0-9]*\.[0-9]+([eE][-+]?[0-9]+)?)$ #float
| # or
^(\d{1,2})$ # 2 digit int/mx';
$str = 'Pass:
1
12
12.3
.3
12.3456789
+12.3
-12.3
Fail
123
12.
abc
12..34
--12.3
.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);