re = /^\s*([-+]?[0-9]*\.[0-9]+([eE][-+]?[0-9]+)?)$ #float
| # or
^(\d{1,2})$ # 2 digit int/mx
str = 'Pass:
1
12
12.3
.3
12.3456789
+12.3
-12.3
Fail
123
12.
abc
12..34
--12.3
.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end