const regex = /^\s*([-+]?[0-9]*\.[0-9]+([eE][-+]?[0-9]+)?)$ #float
| # or
^(\d{1,2})$ # 2 digit int/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*([-+]?[0-9]*\\.[0-9]+([eE][-+]?[0-9]+)?)$ #float
| # or
^(\\d{1,2})$ # 2 digit int', 'gm')
const str = `Pass:
1
12
12.3
.3
12.3456789
+12.3
-12.3
Fail
123
12.
abc
12..34
--12.3
.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}