package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bTotal cash dispensed:\s*\d+\s+([A-Z]+)\b`)
var str = `------>Total cash dispensed: 40000 MGA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}