re = /\bTotal cash dispensed:\s*\d+\s+([A-Z]+)\b/m
str = '------>Total cash dispensed: 40000 MGA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end