$re = '/\bTotal cash dispensed:\s*\d+\s+([A-Z]+)\b/m';
$str = '------>Total cash dispensed: 40000 MGA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);