// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bTotal cash dispensed:\s*\d+\s+([A-Z]+)\b").unwrap();
let string = "------>Total cash dispensed: 40000 MGA";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}