using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Net Amount Due )((\d+.\d+.\d+))|(?<=\n)(\d+.\d+.\d+)";
string input = @"VAT Amount 357,284.55 USD Net Amount Due 730,448.38
Net Amount Due 593,126.84
VAT Amount 0.00 USD Net Amount Due 236,645.35 88,978.652
Tax Amount 161,049.62 USD Net Amount Due 93,416.26
Net Amount Due HU VAT Zero Rated
Gross Amount
USD
72,288.19 0.00 72,288.19";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}