import Foundation
let pattern = #"(?<=Net Amount Due )((\d+.\d+.\d+))|(?<=\n)(\d+.\d+.\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
VAT Amount 357,284.55 USD Net Amount Due 730,448.38
Net Amount Due 593,126.84
VAT Amount 0.00 USD Net Amount Due 236,645.35 88,978.652
Tax Amount 161,049.62 USD Net Amount Due 93,416.26
Net Amount Due HU VAT Zero Rated
Gross Amount
USD
72,288.19 0.00 72,288.19
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)