# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=Net Amount Due )((\d+.\d+.\d+))|(?<=\n)(\d+.\d+.\d+)"
test_str = ("VAT Amount 357,284.55 USD Net Amount Due 730,448.38\n"
"Net Amount Due 593,126.84\n"
"VAT Amount 0.00 USD Net Amount Due 236,645.35 88,978.652\n"
"Tax Amount 161,049.62 USD Net Amount Due 93,416.26\n"
"Net Amount Due HU VAT Zero Rated\n\n"
"Gross Amount\n\n"
"USD\n\n"
"72,288.19 0.00 72,288.19")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.