$re = '/(?<=Net Amount Due )((\d+.\d+.\d+))|(?<=\n)(\d+.\d+.\d+)/m';
$str = 'VAT Amount 357,284.55 USD Net Amount Due 730,448.38
Net Amount Due 593,126.84
VAT Amount 0.00 USD Net Amount Due 236,645.35 88,978.652
Tax Amount 161,049.62 USD Net Amount Due 93,416.26
Net Amount Due HU VAT Zero Rated
Gross Amount
USD
72,288.19 0.00 72,288.19';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);