#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!')'(?!')"
Local $sString = "don't" & @CRLF & _
"don''t" & @CRLF & _
"don''''t" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "''"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)