use strict;
my $str = 'don\'t
don\'\'t
don\'\'\'\'t
';
my $regex = qr/(?<!')'(?!')/mp;
my $subst = '\'\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";