re = /(?<!')'(?!')/m
str = 'don\'t
don\'\'t
don\'\'\'\'t
'
subst = '\'\''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result