$re = '/(?<!\')\'(?!\')/m';
$str = 'don\'t
don\'\'t
don\'\'\'\'t
';
$subst = "''";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;